OpenAPI JSON API endpoint unavailable

Incident Report for Turbot

Resolved

This incident has been resolved.
Posted Apr 02, 2024 - 19:18 UTC

Monitoring

OpenAPI docs are now available again at https://pipes.turbot.com/api/latest/docs/openapi.json.
Posted Apr 02, 2024 - 18:36 UTC

Identified

The external service we depend on for generation is unavailable. We are generating the OpenAPI specification and will remove the external dependency to avoid this issue in future.
Posted Apr 02, 2024 - 10:38 UTC

Investigating

We are aware that the OpenAPI JSON API endpoint is returning an error @ https://pipes.turbot.com/api/latest/docs/openapi.json.

We are currently investigating the issue. All other APIs and services are operational.
Posted Apr 02, 2024 - 10:20 UTC
This incident affected: Pipes (Core Services).